Khoros Community

Occasional Contributor Kgarrison
Occasional Contributor

Freemarker template processing failed

Jump to solution

Hi, I'm pretty new to Lithium and not sure why I'm getting this error. Here's link https://community.cambiumnetworks.com/t5/ePMP/ct-p/forums_epmp I've also attached screenshot. A couple weeks ago under 'Community Structure' I removed one Category that was empty. This message seems to indicate that it's expecting that content 'Product News' to still be there. I checked the Category Page but don't see anything to indicate that I should remove something there. I also removed the Category on staging and pushed that earlier but that didn't fix it. On Chrome: I get a big ugly red box with an error message (see screenshot). In Microsoft Edge: it simply says 'This widget could not be displayed'.

Can someone point me in the direction of fixing this? Thank you!

0 Kudos
2 Replies 2
Honored Contributor
Honored Contributor

Re: Freemarker template processing failed

Jump to solution

@Kgarrison,

When you are logged in with Admin, you will see this error detailed message on community where error occur. For normal users they will only see 'This widget could not be displayed'.

After seeing screenshot of error messaage on your community, it showing that your category with id "product_news" is not available on production in the custom component "ProductNewsComponent".

Go to ProductNewsComponent custom component in your studio and remove this category id from the reference in your API.

.......
Do you know we work with Kudos and Accepted Solution.
Reply
Loading...
Occasional Contributor Kgarrison
Occasional Contributor

Re: Freemarker template processing failed

Jump to solution

thank you Parshant! I found that custom component and that ID was referenced 14 times. Considering that we removed this category all together I tracked down the page template that contained the 'ProductNewsComponent' and just removed it from there. I had looked under Category -> Category Page but it wasn' there. This time I found the template under Custom -> CategoryPage.CN_Forums_Product. Your insight definitely helped.

 

best,

Kurt

Reply
Loading...