Public
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Occasional Advisor

bug? Roles not transferring to sub-sections?

So - we're creating a section in our community.

We want to restrict access only to signed in community users.

I saught advice and was told it was as simple as setting the default access to the community to restricted.

Then change the permissions of the role of "community member" to be able to see it, so the section needs to be logged in to view.

However when under the sub-section, the roles do not carry.

I raised this and was told that you can create the role again in the sub-section, and if the name is the same then it should bring the same users from the roles across.

 

I dont know what im doing wrong here but It isnt showing me the users under the role.

Am I overcomplicating this, is there a simpler way to stop anonymous browsing on specific sections?

 

 
 

back end.png

8 Replies 8
Moderator

Hi Morgan,
As per the current behaviour, creating the same role in a child node will not show in the child node, the users added to the role at a parent level.
But within that child node,  the users with the parent role will have permissions as per the child node role definition. So if a permission is granted in the child node, the users with the parent level role will be able to take that action in that child node, even though the role was not explicitly assigned to users in that child node. 

I think im misunderstanding how you apply the rule to role within the child node, if the role doesnt exist, you re-create the role with the same name.

But the rules dont seem to be applying to the members of the same role at the parent level.

 

Any help would be appreciated. 

Honored Contributor

What are the default permissions you have vs. the permissions for the Community Member on the node you are trying to gate?

in the node we're locking down, ive restricted everything.
Then ive set the persmissions for the community user role as what was the usual "default" roles.

 

The issue is, the community user role (at this level), doesnt seem to have any users in it.

I can add the users to the role, but then any new users to the community also need to get added to the role at this level.

 

It surprises me that this isnt like a default option.... unathenticated users can view. default yes. at node level, no. problem solved. 

 

But unless im being stupid, i cant see this option

Honored Contributor

Depending on how the other parent nodes are setup, you can't hide/unhide/hide/unhide content the deeper you go. There is limits to how permissions work (which is where things get extremely complicated). It looks like you have this buried a few deep, so depending on how each parent node above it is configured will have impacts on how this is working.

every node above this in the heirarchy is running the same default options as the home page... =/

 

Help me Grobie-wan, youre my only hope.

Honored Contributor

What's the default node permissions look like vs. permissions for the community member role setup on there?  Include full screen photo of each as it sounds like something is off on one of them (or so I would think).

Occasional Advisor

Update: Its because the "logged in/non-admin" user account I was using to test didnt have the "community member" role....

So, yes, it was me being stupid.

Welcome to the Technology board!

Curious about our platform? Looking to connect on social technology? You've come to the right place!

Are you a Khoros customer? For direct assistance from our Support team, please visit the Support Forum.