Public
Advisor

Attachments on some TKB articles not visible

I have several TKB articles that have attachments on them. My community users can see the attachments on some of these articles, but not others. I am wanting the attachments on all the articles to be visible to my users. I've been unable to find any settings that control attachment visibility on a per-article basis - can anybody think of what settings may control this that I should check?

NB. The articles are in the same TKB category, and the attachments have the same extensions - so the lack of visibility of the attachments doesn't appear to be related to category settings or attachment filenames.

3 Replies 3
Khoros Staff

How do you know the attachment is there when it isn't showing? Have you tried inspecting the post with the browser dev tools to see if the markup for the attachment is there?

Having attachments only appear on some posts but not others in the same board is very unusual.

-

Professional Services - Sr. Web Engineer

Advisor

Thanks for the thoughts @MattV. I know the attachment is there because it admin users can see it.

But I managed to get to the bottom of this problem after some further digging: I found that the community has a custom component configured which shows or hides attachments for different users based on their roles. Whether or not we really want that behavior in place is a question for another day; at least know we know what is going on!

@cgrinton - Must have been customization in place as you mentioned. Let's connect and see when and why this was implemented. 


Varun : Weaving magic with Khoros!

Recent Ideas: Advanced Private Messages | Rewarding Module | Badges for Threads

Welcome to the Technology board!

Curious about our platform? Looking to connect on social technology? You've come to the right place!

Are you a Khoros customer? For direct assistance from our Support team, please visit the Support Forum.