Public
Valued Contributor

Is this a bug? Insert Code is showing emoticons

We are a technical community and love the Insert Code option.  Since this is specifically offered for inserting code, why are emoticons enabled in this box? 

I would not expect emoticons to appear when an engineer tries to write a colon followed by a p. 😛  

Our members are understandably complaining about this behavior.  I consider this a bug. 

Should I submit a ticket to support?

 

 

5 Replies 5
Khoros Guru

@mhock - This should be configurable. Can you please try toggling the setting Turn off emojis within preformatted text under Community Admin -> Display -> Emojis. That should hopefully resolve the issue, I see this setting is not checked on your community currently.

Chad B.
Technical Support Lead
Khoros

Valued Contributor

@ChadB 

Thanks for the quick reply.  Sorry for my delay.

As I reviewed the hover over in the Community Admin, it appears this turns it off for the entire Community.  Is there any option to only have it off in the "Insert Code" feature? If not, can you explain the purpose of insert code if it doesn't take the content as plain text?

Melissa

@mhock - This setting is designed to disable emotion shortcuts within any PRE HTML tags, which the Insert Code function leverages. I would not expect it to impact other areas of the community unless PRE tags are getting leveraged elsewhere. I just tested it on your staging environment and it seems to work fine for me:

emoji_insert_code.PNG

This is what the HTML markup looks like from that post:

<p>test :)</p>
<pre>test :)</pre>

 

Just confirming you toggle the setting "Turn off emojis within preformatted text" and not "Turn off emojis everywhere"? I left the settings as-is on stage if you'd like to review there.

Best,

Chad B.
Technical Support Lead
Khoros

Valued Contributor

@ChadB 

Thanks for going the extra mile to check the functionality.  In my post Turkey stupor, I didn't even see the second option on the page.  That is truly pathetic.

I have enabled it and will have happy developers.

Thanks again!

Melissa

Occasional Advisor

Note to users using this solution. There was a change on the Khoros side of things that caused all emojis to be turned off when selecting to turn off emojis with performative text. You now need to use the settings below to have the option for emojis in regular text and not to have them in code blocks.

 

Screen Shot 2021-09-17 at 9.27.06 AM.png

 

Welcome to the Technology board!

Curious about our platform? Looking to connect on social technology? You've come to the right place!

Are you a Khoros customer? For direct assistance from our Support team, please visit the Support Forum.