Khoros Community

Valued Contributor
Valued Contributor

Can't get these permissions right!

Do you ever have one of those days where you CAN'T get a role's permissions right? Well after a 7 of those DAYS, I'm here asking for HELP. 🙂 Hopefully someone can point my in the right direction, because I know my issues are user error!

Here is part of my Community structure. I am trying to create a discussion forum that only "ServiceMax Employees" and "SFM Designer Beta" roles can see. See the SFM Designer Beta forum below.

Screen Shot 2019-08-09 at 2.27.20 PM.png

Everything above "SFM Designer Beta" is open for the whole world to see, logged in or not. Right now I have it hidden from people not logged in, but once you log in, regardless of your role, anyone can see it.

How do I get it hidden from everyone except users with "ServiceMax Employees" and "SFM Designer Beta" roles?

Please let me know if there's other screenshots I can provide! I've stared at this screen for too long. Thanks!

screencapture-community-servicemax-t5-bizapps-bizappspage-tab-community-admin-users-node-display-id-forum-board-SFMDesigner-Beta-2019-08-09-14_44_38.png

 

0 Kudos
9 Replies 9
Honored Contributor
Honored Contributor

Re: Can't get these permissions right!

Hi @nicoleguzzo - 

I've definitely been there too. Khoros permissions are a BEAST.

I'm not 100% sure if this is best practice, but when I'm making a private forum / category, I always just make sure EVERYTHING is denied. Maybe adjust all of those green squares to "Deny"?

----
Caroline Sekar | Community Manager @ Cisco Meraki | @merakicaroline
Reply
Loading...
Trusted Contributor Trusted Contributor
Trusted Contributor

Re: Can't get these permissions right!

Oh no! This is a tricky one! I wonder if the board is inheriting permissions from the parent boards above it. I reckon if you moved the private board out of that category and made it its own category, that would work. 

To further troubleshoot, you might want to share a SS of the Roles tab and then what permissions the roles that show up on that tab have. 

Thanks!


Reply
Loading...
Highlighted
Khoros Guru
Khoros Guru

Re: Can't get these permissions right!

In short the approach is indeed:

  • Remove viewing permissions on that node for the default user
  • Add viewing permissions for the roles on that node using the "Roles" tab on top of the permissions.

The long version of the instructions - including screenshots - is to be found in the article "Create a private forum"



If you appreciate my efforts, please give me a kudo ↓
Accept as solution to help others find it faster.
Reply
Loading...
Valued Contributor
Valued Contributor

Re: Can't get these permissions right!

Thank you @ClaudiusH @AlanA @CarolineS for your responses! Still struggling - but going to delete and restart again, with a clean slate. 

Reply
Loading...
Trusted Contributor Trusted Contributor
Trusted Contributor

Re: Can't get these permissions right!

Best of luck! 


0 Kudos
Reply
Loading...
Khoros Guru
Khoros Guru

Re: Can't get these permissions right!

One pitfall could be testing with an admin user: As an admin your permissions would override the default. So I suggest testing in an browser incognito window and with a normal user account that you create. Just to rule out the admin "god mode". 🤡



If you appreciate my efforts, please give me a kudo ↓
Accept as solution to help others find it faster.
0 Kudos
Reply
Loading...
Advisor
Advisor

Re: Can't get these permissions right!

@nicoleguzzo,

I was just fighting with this yesterday.  Nearly every time I create a private board I struggle with this so I always reference this great article from @JohnD 

https://community.khoros.com/t5/Forums/Create-a-private-forum/ta-p/109143

It talks about a private board in a private category but you can skip that part.  

This one has worked for 3 private boards I have created thus far.

And I agree with @CarolineS, permissions are a BEAST!!!

Good luck!

Melissa

0 Kudos
Reply
Loading...
Honored Contributor
Honored Contributor

Re: Can't get these permissions right!


@CarolineS wrote:

I'm not 100% sure if this is best practice, but when I'm making a private forum / category, I always just make sure EVERYTHING is denied. Maybe adjust all of those green squares to "Deny"?


After reading the responses below, and the "Create a private forum" document - I have learned the error of my ways!! DON'T follow my advice about setting everything to denied. I just tried it out with just blocking "See forums" as recommended in the "create a private forum" document and - SO MUCH EASIER. That way the other default permissions propagate and you don't have to re-create each role from scratch (not sure I'm explaining it well, but.... just follow everyone else's advice :-)). 

----
Caroline Sekar | Community Manager @ Cisco Meraki | @merakicaroline
0 Kudos
Reply
Loading...
Honored Contributor Honored Contributor
Honored Contributor

Re: Can't get these permissions right!

Hi @nicoleguzzo : I worked on the permission remap of our community and hope my expertise will help here:

As per my understanding "SFM Designer Beta"Board should be only accessible for users with any one of the roles "ServiceMax Employees" and "SFM Designer Beta"?

 

1.Navigate to SFM Designer Beta Board in the community structure --> Users--> Permissions--> Deny "Read Posts","Submit Posts",Start Topics" and "See Forums"

2. Navigate to the  Role tab in the same path (SFM Design Beta) and create both  roles "ServiceMax Employees" and "SFM Designer Beta"  and make all Deny permission in Step 1 in to Grant.

3. Now try to assign any users with the roles and only user with the roles will now able to access the board.

 

If you appreciate my efforts, please give me a kudos
and Accept as solution to help others find it faster.If my post is helpful and answers your question, please give "Kudos" and "Accept it as a Solution."

Thanks & Regards,
Abhishek Illindra

 

0 Kudos
Reply
Loading...