Showing results for 
Show  only  | Search instead for 
Did you mean: 

Tables and Headings in TKB cause top of article to be cut off / hidden

We have run into an issue several times where we are either posting a new TKB article or editing an existing article, and if we use any tables or headings, when we save the article a top chunk of the article is hidden / cut off.


Here is a screenshot of the top of the article when in edit mode:



Here is the top of the article after saving it:



Here is the top of the article when I go back in to try to edit it again:



As you can see in this final screenshot there is text above the editing window, but the scroll bar is all the way at the top. If I actually click into the editing window, the article goes back to what it looks like in the first screenshot above. However, when I save it again, the top is still cut off. I've tried adding line breaks, and that doesn't help either.


What I ended up doing as a workaround is to take a screenshot in editing mode, save it as an image, and then upload the screenshot into the editing window. This is NOT a workable long-term option because the text in an image is not searchable in the Community.


Also, I even had to save, edit, save to get the top of the uploaded screenshot to display. I had the cursor set and the heading set to "paragraph," and saved it, but the top of the image was cut off. When I went in to edit it, somehow there appeared a line break that was set to "Heading 1." When I reset the heading to "paragraph" and re-saved, then the image displayed properly.


Has any other customer out there experienced this? Have you found a way to fix it? @KhorosSFDC - Can you please help with this?


3 Replies 3



Looks like you may have found a bug with the TKB editor, do you have the same problem in different browsers?


If you have access to the Case Portal in Knowledge & Support I'd recommend submitting a ticket there for the team to look into it further, reference this topic in the support ticket.


Guide to reporting issues


Let us know how you get on


Click the Kudos button below if you find my posts helpful. If I've answered your query please click the Mark Solution button to help others find the same answer.



I've tried Chrome, Firefox, Edge, and IE. Same behavior in all.


I've asked my manager to submit a ticket to Support since I do not have access to the portal.



I just want to add here that Support was able to provide us with a solution to this problem. Below is the response:


I have looked into the issue and it seems you have set some negative percentage margin for header tag and following CSS is the root cause of the issue

.MinimumWidthContainer .min-width-wrapper .min-width .lia-content .lia-quilt .lia-quilt-row .lia-quilt-column .lia-quilt-column-alley .lia-quilt-column-alley-single h1 { 
margin: -20% 0 0 0 !important; 

The margin should set to 0 or positive value, which is the best practice while implementing CSS and below is the CSS which can fix the issue

.MinimumWidthContainer .min-width-wrapper .min-width .lia-content .lia-quilt .lia-quilt-row .lia-quilt-column .lia-quilt-column-alley .lia-quilt-column-alley-single h1 { 
margin: 0 0 0 0 !important; 


Welcome to the Technology board!

Curious about our platform? Looking to connect on social technology? You've come to the right place!

Are you a Khoros customer? For direct assistance from our Support team, please visit the Support Forum.