Public
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Expert

Twitter Posts from Community - not showing images

I've been all over Atlas and can't seem to find this.
When we simply add a link from a TKB into Twitter we get this during preview and after publish.

Peter Silva _ Microsoft Teams 2022-04-07 15-35-35.jpg

 

 

 

 



e.g., links that should work because they have a cover photo.
https://community.f5.com/t5/technical-articles/protect-applications-from-spring4shell-cve-2022-22965...

And even embedded images in the TKB body.
https://community.f5.com/t5/devcentral-news/devcentral-s-featured-member-for-april-scott-campbell/ta...


Where I have looked:

This article can have a cover photo or embedded images and none of them display in that twitter card.

Nothing really hits it tho - possible exception of the robots.txt post except that is focused on Marketing and so...?

What do I have to do to allow Twitter link cards to catch my cover-photo images? Or embedded images?
OR, as a last ditch effort, even my community logo?

4 Replies 4

You are looking for open graph in admin settings.  You can set an image per node. If you want to have it pickup the cover photo it requires a bit of dev work I believe (it’s broke. In our own community and planning to try to tackle it next month). Search open graph on atlas you’ll find a lot more posts  

https://community.khoros.com/t5/Integrating-with-Facebook/Change-how-the-shared-topic-appears-on-Fac...

 

 

Expert

@StanGromer for president! 💯
Thanks - worked like a charm.

I'll put the CoverPhoto request in to my dev. 

Expert

Interestingly - It worked immediately for me, test cases n=1.
All my other teammates - still show that small paper icon in their previews - even for the same link.
So I changed the logo in the open-graph field to use one in our set that we provide to iphones, and android icons etc; a PNG and definitely publicly avail image. And it took a few minutes (caching?) before my preview picked up the new open-graph image. Ok - great.

Still, none of my other teammates get the image in their previews.

Further testing n=6+ shows it works for some links but not others?
I don't see a pattern between the Works and NotWorks.
* CoverPhoto
* !-CoverPhoto
* Included Images
* !-Included Images

Further confusion - sometimes I get the original logo I provided to OpenGraph and sometimes I get the NEW logo I provided to OpenGraph.
Tried new browsers - same confusing behaviors.
Tried deleting all twitter cookies and re-logging in - same confusing behaviors.

I suppose my next step is Support?

@Lief You'll need to allow at least ~24 hours before trying to test anything truly as best I understand it (Someone may correct me) - It does cache, but at the service provider level so you have to wait for Facebook/Twitter/Google to all refresh everything on their end. I've found with Facebook this is all over the place, one refresh it works, computer next to me won't see it until 12 hours later though.

This site also can help test -> https://www.opengraph.xyz/

Welcome to the Technology board!

Curious about our platform? Looking to connect on social technology? You've come to the right place!

Are you a Khoros customer? For direct assistance from our Support team, please visit the Support Forum.