Showing results for 
Show  only  | Search instead for 
Did you mean: 

"Request entity too large" errors?


One of our superusers is reporting that he has gotten "Request entity too large" errors pretty regularly (~daily) for about the last month, on Chrome. I'll file a support ticket, but curious if anyone else is getting reports of these.




9 Replies 9

Take a look at this article:

An oversized cookie might sound delicious, but sometimes, it's just too much...

We ran into the same issue back in 2020 using our "old" SSO method and had to have Khoros increase the Apache header size to accommodate an ever-growing range of authenticated tools packed under the same cookie. It pretty much solved our issue, and it hasn't come back up since we moved to Azure SSO.

The workaround (prior to a support case) was to have the user delete their * cookie from the browser.


Community Manager \\ NetApp

Thank you @Drew_C! I probably should have searched first before I posted this; didn't expect there would be an "FAQ" about this issue! 

Oddly enough, I think the same'ish thing is happening to us this week. Happened to me randomly this week, I ignored it.  Now happening to dozens of folks 😞 



Too funny @CarolineS 

We have one user, just one user in our community that hits this error constantly and they happen to be our most active member, by a noticeable amount.

It's a staff member thankfully so I've always shared the cookie workaround but now I'm wondering, how many external folks might hit this?

We haven't explored changes with support since its just a single user but I'm curious @Drew_C if you recall what the default header size was, and what header size you went too? 

I just found the ticket where I made the request... we went from the Apache default of 8 KB to 16 KB.

Here's some commentary from the ticket:

Currently your community is set to Apache default header size of 8KB.

While we don't recommend it for potential security and performance reasons, based on my encounter with other communities when they report this error, increasing the header limit to 32K addresses this issue and if the issue still persists then the header size can be further increased beyond 32K.

Hope this helps!


Community Manager \\ NetApp

Apparently there is a max size, and we already hit it, so Khoros has us generating a HAR file to troubleshoot it more.  Waiting to hear what the max size is, as based on @Drew_C's post I would think they just keep increasing it up.


I am receiving both of these messages, Bad Request and Entity too large.  I have created multiple tickets with Khoros Support who just keeps telling me to clear my cache.  I want to know why this is starting to happen in the last couple of months.  I'll provide an HAR file to Support next time I receive the message.

We implemented sso via jwt token this year, but I wouldn't think it would cause it.  We also built a new sync so run API from SF to Community when a user logs in a couple of months ago.  Do we think maybe it is too many API requests?  Khoros turned off our API a few months ago because they had an alert of too many requests.

@jamiemccardle - Khoros support bumped up our default header size w/ no pushback when i requested it (based on Drew's advice above). Maybe ask them to bump from 8kb to 16kb and see if it helps?



I reached out to Support and they said the following.  Thanks for the suggestion.


"I am reaching out to let you know that we have increased the apache header size even further in an attempt to fix this issue.

The issue should now be fixed, and you should not get any errors as mentioned. Please check on it and let me know if you have any further queries in this regard."

Welcome to the Technology board!

Curious about our platform? Looking to connect on social technology? You've come to the right place!

Are you a Khoros customer? For direct assistance from our Support team, please visit the Support Forum.