cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

No spellcheck in blog comments

No spellcheck in blog comments

0 Kudos

I just noticed I don't have a spellcheck button in my text editor when writing comments on blogs. I also noticed there is no spellcheck button when writing a regular post (like this one) but the spelling is checked as I type. It isn't checked in the blog comments though.

 

spellcheck.png

6 Comments
Retired Community Manager

Hi @lilim, we're trying something new with our spell check on the Lithium community, and disabled the button in TinyMCE and are using the native spellchecker of browsers. If you're using Firefox and are experiencing this issue, you may need to download their dictionaries.

Boss

Thanks for the reply, Jenn! Nice to hear about this update. Cat Happy

 

Unfortunately, I do have the Firefox dictionaries added already, and I'm seeing this issue with blog comments in Chrome and IE 11.

Boss

I just noticed in the text editor for a blog comment, it gives me the option to Add Dictionaries in Firefox. I go through that process, but nothing happens.

In the text editor for a regular post (like this one), I already have the English dictionary installed. I also see it in my Add-ons Manager > Dictionaries.

Boss

Indeed the Firefox spellchecker isn't working on blog and idea comments here on the Lithium Community, but it does work in discussion and group replies. For some reason the 

spellcheck="false"

attribute is set for the TinyMCE editor element there. So sounds like disabling the spellchecker is not honored there.

Khoros Oracle

Guilty as charged - I forgot to update the comment editor Smiley Surprised

 

Working on that now. Sorry!

 

Edit:  Fixed!

Moderator
Status changed to: Resolved